Xcode 6 error “Embedded binary's bundle identifier is not prefixed with the parent app's bundle identifier.”

Xcode 6 error: “Embedded binary’s bundle identifier is not prefixed with the parent app’s bundle identifier.”

  1. Question by chitza
  2. Answer by Milovan Tomašević

Question by chitza

I’m trying to build an extension project and Xcode keeps throwing the error in subject.

Xcode log error

Needless to day, the extension’s bundle id is prefixed with app’s bundle id.

Product Name: ro.chitza.TodayPics.$(TARGET_NAME:rfc1034identifier

Extension bundle id

I’ve tried cleaning the build folder and rebuilding, no luck. The funny thing is the entire project got built for a few times, but after some code and UI changes it started failing. Even if I create new projects, the same thing happens after about 5-6 builds.

Did anyone else encounter this error? Any hints for a solution or workaround?

Answer by Milovan Tomašević

For xCode v12 I solved that problem with one click:

TARGETS -> Build Phases -> Embed App Extensions

and check: Copy only when installing

enter image description here

Improve this page: 

Share on:      

Comments 💬